I've had a Samsung Galaxy S3 for a few years, I even upgraded to a newer model, and revered back to my trusty ol' S3 because I missed it, and was and was happy with it's size & features.

Eventually the USB charge port stopped working (a common problem on this model). Replacement part is under $2 but microsoldering & board repair are beyond my skill level, so I got a 2nd battery + external charger, which I've been swapping out twice a day for six months.

It's a bit of a pain, so when I realized Qi-style Wireless Charging could be inexpensively "retrofit" to my device, I was thrilled!

The transmitter & receiver pad arrived yesterday. I placed the pad under the battery cover as instructed (touching the previously-mysterious 2nd set of charging contacts), put it on the transmitter, and voilà, my charging headaches were solved! It charged faster than plugging it in [used to], and even worked with my rubber case attached.

Hooray! Until the next day. :-(

Today the phone does not detect the wireless charger. I've tried restarting the phone repeatedly, tried two batteries on each of two receiver pads (they accidentally sent 2 instead of 1), tried with/without case & cover, and even different power sources & cables to the transmitter.

None of these steps worked which leads me to believe this is a software problem... Is that possible?

If I can't get it working I'm obviously going to send the parts back and go back to constantly swapping batteries but I'm hoping someone has a suggestion. Could there be settings I am unaware of?

When working, Ampere Meter app said it was charging wirelessly at 1050mA. Receiver pads are rated for 800Ma; Batteries are 3.87v/7.98/Wh/2100mAh. As I recall it would charge around 650mA back when the charge port worked.

Photo is similar receiver pad, on same model of phone:

Wireless Charging Receiver Pad Installation on Samsung Galaxy S3

Samsung Galaxy S3, rooted (with no other issues), running Kitkat 4.4.4.
  • Couldn't you just take your phone to a service centre? Nov 26 '17 at 14:35
  • Warranty was gone a long time ago. The goal is to not spend any money, and to keep my existing phone. After trying all the hardware combinations I could think of, I was hoping there might be something software-related I could try.
    – ashleedawg
    Nov 26 '17 at 15:11

Oddly, my receiver (NillKin) stopped charging the phone on the same day as yours did. I have a Pixel XL (Android 8) & this solution worked great! ...until it didn't. Try turning the phone off & see if it will charge. Mine still will, but only if turned off. I do notice that I have to be more precise with placing it on the pad than I used to. Only thing I can think of electrically that matches the symptoms would be if there are multiple wires used in the loop & one is either shorted or ground. ??? Anyway, I ordered another one that should be here in a couple of days.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.