I have a Sony Tablet S, for which I am not aware of any method of rooting. On this device there is an amount of internal storage (dependant on model 8 - 24 GiB) and an external sdcard slot. The former is mounted as /sdcard and the latter as /sdcard2. My usage of the device would be made a lot easier if I were able to access sdcard2 from within sdcard (when mounted).

I have not found any way to do this without root access (tried ln -s but it turns out the partitions are FAT) - has anyone else got any ideas? It is very annoying as I am unable to access my media on the large external storage card I have bought with many applications - I have found myself buying a music payer that specifically allowed me to type my own search paths for media libraries, but cannot use DNLA to send this media to other devices, instead having to remove the sdcard and put it in my laptop - less than ideal...

1 Answer 1


Do you know how the internal storage is formatted? If it's FAT then there's not much you can do.

Otherwise you could do something like this from adb shell or from a terminal on the phone:

cd /sdcard
ln -s /sdcard2 <name>

For example, if <name> was sd2 then you can now access it via /sdcard/sd2/.

  • 1
    AFAIK, internal storage is FAT, otherwise windows would not be able to mount it, so I don't believe linking would be possible. Also, wouldn't creating a sym link require root? Jan 24, 2012 at 19:42
  • 1
    @Ryan Ah, fair point, though I also don't know anything about whether this tablet lets the PC mount the internal storage :P. As for requiring root: Nope, not if you have user write privileges to the folder where you're creating the link. For example ln -s /mnt /data/foo works fine for me in an unelevated shell. Jan 24, 2012 at 20:10
  • Sorry the storage is FAT- was hoping there might be a way such as placing a shortcut from a computer or a command I had not tried. Jan 24, 2012 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .