0

I somehow bricked my OnePlus One phone badly. It only loads directly to the recovery. Pressing vol up + power button or rebooting it with adb reboot bootloader doesn't get me to the bootloader. I think I erased the bootloader partition or deleted my bootloader.

Here comes the tricky part. I can't even sideload any file or access my internal SD card because then I get either following error messages:

  • E: footer is wrong
  • E: signature verification failed
  • Error opening '/data/media' (no such file or directory)

Right now I can either flash the OnePlusRestoreTool(64GB) recovery or the ColorOS recovery tool (both can't access the internal storage - button is not clickable). I thought I just have to mount my SD card new, but I can't enter a shell command, and most badly, I can't enter the bootloader.

How to fix it?

2
  • Have you tried doing what you have done from an administrator command line? I was having similar issues on my lenovo and redmi devices but when I switched my account to root(I use Arch Linux, in windows you would obviously have to 'run as administrator') and ran the commands everything worked perfectly. Commented Feb 27, 2021 at 14:48
  • Further specifying more details would probably attract the people with the right skill to help. This includes the exact model number/codename(eg: Redmi 4X/santoni), any system logs you might be able to get hold of(you will find this hard since you say you can't access anything). Another thing you could try doing is formatting your device from TWRP's wipe section. This solved an issue I had covered here There might just be the slightest chance you are having trouble because of encryption. Commented Feb 27, 2021 at 14:54

1 Answer 1

0

Since you can boot into recovery, reflash your ROM - make a clean flash (wipe cache, Dalvik cache, system, and data.)

If you can't flash through TWRP, then you have to use the flashtool.

2
  • Sry, but I can't adb push any file on my phone. even sideload doesn't work. no shell command does work (so I can't mount or unmount my sdcard).
    – user244972
    Commented Nov 28, 2017 at 21:58
  • If you can boot into fastboot mode then you could try flashing TWRP again, then doing "fastboot boot recovery <name of TWRP image>.img". After that format your storage, install magisk and only after that install a custom rom. Install Gapps only after you can ensure everything else works properly. Commented Feb 27, 2021 at 14:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .