My device (unrooted samsung s5, latest google chrome browser version) keeps navigating to https://www.google.com to (eventually) access a public wifi's login page. This is problematic of course as the actual wifi "sign-in" page (that I'm supposed to be forwarded to, or the http redirection for it) is obviously not signed by an ssl certificate for www.google.com, so I get the expected ssl error message.

Is there some setting I can change to change the default wifi sign-in address for the android chrome browser?

  • Refer to answers below this question for how to change the captive portal server, or how to disable the mechanism altogether. – Andy Yan Nov 27 '17 at 2:58
  • Just guessing as I played with those settings last night. The setting is most likely captive_portal_http_url. Not sure if it can be set without root e.g. via adb shell, but it the syntax would be settings put global captive_portal_http_url http://www.example.com/page (of course replacing the URL by yours). See here for the other settings. To reset: settings global delete captive_portal_http_url. Use settings global get to check the original setting first ;) – Izzy Nov 27 '17 at 7:23
  • 1
    @Izzy It's possible to set it without a root shell, I do it on new devices I set up. – Andy Yan Nov 27 '17 at 15:01
  • Thanks, @AndyYan – did you also play with the URL parts, to define a "custom portal server"? And if so, using http or the https variant? If someone succeeded with that, it would make a good and interesting answer! Some detailed description of those parameters (and their usage) would also be nice. But I guess that should go to a different question I've just posted (I don't want to hijack this one ;) – Izzy Nov 27 '17 at 15:23
  • Since the default Google server is unreachable in China, I have to define a custom URL. I only had to do the https command to make it work. Thing is, I feel the original question I linked to already has some answers that explains the whole mechanism quite nicely, only the command to set the URL wasn't updated for Nougat (captive_portal_http(s)_url instead of captive_portal_server). I'll sum up some info I can find and see if it's worthy of an answer over there. – Andy Yan Nov 27 '17 at 16:11

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.