I downloaded a compiled lynx binary from XDA and everytime I start lynx it tells me that it is unable to connect to remote host. I changed the lynx.cfg to use localhost and it loads, but when I enter an URL, nothing. I tried it with 3G, 2G, and WiFi, and had no luck. What should I do to get it work?

  • Firstly why? I can remeber using Lynx back in the mid-90s, not something I'd ever want to go back to! Secondly, a few of the people on that XDA thread also mention that exact error, have you tried asking there, the user that created the Lynx binary seems to be trying to help with the problem but no one's taking him up on it.
    – GAThrawn
    Commented Jan 25, 2012 at 11:34
  • I am using vim in Terminal IDE and need to copy some URLs. I am unable to copy the URLs from android into Terminal IDE. So my only other alternative is to use lynx, links, or elinks. I found this lynx, but if you have a better option, I am all ears. Also, my phone is not rooted. I tried registering with xda but I need to answer other people's questions before I can reply in that thread, and seeing as I do not know anything about this stuff, that option is sadly unavailable to me. So my options are learn how to copy into Terminal IDE or get a bash based browser.
    – thequerist
    Commented Jan 25, 2012 at 21:00
  • "copy some URLs"? Do you mean, paste the literal URL ("foo://bar/etc") into the terminal? If so, just select and copy the URL in some other app, and use the menu in TIDE to paste them. Commented Feb 21, 2012 at 3:32
  • Yes, the developer added that feature. Works great!
    – thequerist
    Commented Feb 21, 2012 at 4:36
  • I'm afraid this has become an XY-problem. This question is valid, but the accepted answer is in no way answering the question, but to the question in the comment. Meanwhile, from a recent answer, it seems that TIDE itself has links-2.7, which seems to be the alternative method. Consider to update the accepted answer if it helps you.
    – Andrew T.
    Commented Mar 30, 2015 at 3:19

2 Answers 2


I found it !
Download Terminal IDE, it is an awesome shell for Android.
Installs the additional packages from within the app to get :
GCC, make 3.82, ssh, sshd, telnetd, bash, busybox, vim, mc, htop, TMUX, links 2.7, rsync, git, and more !

  • So much good in this software. rsync on my phone is plain awesome for backups.
    – Irving Poe
    Commented Mar 29, 2015 at 22:31

The problem is that DNS binding support is different on Android. Lynx, wget, etc, if statically compiled by standard GCC under Linux, will not be able to lookup the domain name, but would work with a numerical ip address. You can see that problem in many of the busybox implementations for Android.

There is some discussion of this at Kevin Boone's KBOX2 Project

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .