When I type something into the search box at the top right of the main page, I get a Next key instead of the Go or enter key. If I enter text in search, pressing Next takes me to the interesting tags input, then to the ignored tags input; pressing Go from there takes me back to the main page, with my search text sitting in the search box and no way to do anything with it!

My phone is a Galaxy S and I've tried all three of the input methods -- Swype, Samsung and Android -- and all behave the same way.

From https://android.stackexchange.com/search (it's the same text on other SE sites):

To search, type in the box at the top right of every page and press Enter.

How can I provide the Enter that the search functionality depends on? If I can't do it directly, are there any workarounds?

(I'm certain I've run into this problem on other websites too, but I can't think where right now.)

  • Works for me on HTC Desire... must be a problem specific to your phone.
    – Mark Byers
    Oct 3, 2010 at 15:29
  • @Mark: I wondered why nobody else had noticed it before now. :)
    – Niall C.
    Oct 3, 2010 at 15:40
  • @Niall: I Uber Keyboard on my Moto Droid, and I also tried the stock keyboard and on both I'm given the option to "Go" in the SE search field.
    – Matt
    Oct 3, 2010 at 17:33
  • That's odd, I can confirm I'm seeing the same thing on my Vodafone UK Galaxy S (Eclair 2.1 update 1, build JM4). I don't actually search much on StackExchange sites, I'm more of a browser so never noticed before. On the full /search page the only box that's gives me a "Go" button is the DuckDuckGo box.
    – GAThrawn
    Oct 4, 2010 at 0:23
  • which browser are you using? Nov 16, 2010 at 15:11

1 Answer 1


Don't if there's something on the StackExchange sites that has changed, or if the Froyo update has fixed this, but I do get the Go button now, not a Next button when I type into this site's search box on my phone.

(Vodafone UK branded official Samsung Galaxy S 2.2 Froyo release JP7)

  • I'm still seeing Next on 2.1, so it's probably the 2.2 update. I'll confirm if and when T-Mobile USA gets around to releasing it to their customers.
    – Niall C.
    Nov 16, 2010 at 14:08
  • Even with my hardware keyboard on my Moto Flipside (2.1) pressing the return key doesn't work. :-(
    – travis
    Feb 6, 2011 at 17:31
  • Oops, I completely forgot about this question. It works now and I'm pretty sure it was after I installed the Froyo update.
    – Niall C.
    May 27, 2011 at 18:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .