0

My G935F shows "Could not do normal boot invalid kernel length" when attempting to boot into TWRP or turn on the device normally. The only thing I can access is ODIN. This happened after attempting to update TWRP and LineageOS. From looking online, I believe I can get a kernel and select the AP option in ODIN and flash a kernel as long as it is in .tar format. I was previously using PRIME kernel https://forum.xda-developers.com/s7-...1-4-0-t3678159 so I looked in the latest download from there but there are no .tar files, only a bootimg.tar.xz and a ramdisks.tar.xz. I tried extracting bootimg.tar.xz to a bootimg.tar and flashing that, but ODIN says it failed: Added!! Odin engine v(ID:3.1210).. File analysis.. SetupConnection.. Initialzation.. Get PIT for mapping.. Firmware update start.. NAND Write Start!! SingleDownload. g930eur-aosp-Image-r12p0 Unassigned file Complete(Write) operation failed. All threads completed. (succeed 0 / failed 1)

I also tried flashing the zip from https://autoroot.chainfire.eu/#odin but ODIN gave me: Added!! Enter CS for MD5.. Check MD5.. Do not unplug the cable.. Please wait.. CF-Auto-Root-hero2lte-hero2ltexx-smg935f.tar.md5 is valid. Checking MD5 finished Sucessfully.. Leave CS.. Odin engine v(ID:3.1005).. File analysis.. SetupConnection.. Complete(Write) operation failed. All threads completed. (succeed 0 / failed 1)

I don't know what I'm doing and I'm afraid to mess up my phone beyond repair with ODIN. Can someone please help me? XDA forums has no answer and I don't know who else to ask.

0

I ran ODIN as administrator and was able to flash Chainfire. I was then able to boot in normally, and after that flash TWRP again. Still not sure which step caused that issue but it is resoled now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.