I'm trying to reboot my Xperia M4 Aqua into bootloader mode but all it does it turn it off and I get the battery charging image as if the phone is shut down and in charge.

I tried using the commands

adb reboot-bootloader 


fastboot reboot-bootloader

and I also tried doing it manually by pressing volume up button while inserting the usb cable in... same results.

The command

adb devices

returns the device while

fastboot devices 


OS is Windows 10

1 Answer 1


Thanks for enlighting me; I always use without hyphen

adb reboot bootloader

which is in line with syntax, but for curiosity tried couple of moments ago on Moto G4 with hyphen successfully

adb reboot-bootloader

But, in what mode you issued command

fastboot reboot-bootloader

Because you are using Windows platform, acquire appropriate drivers for that device.

In developer options, both Enable OEM unlock && USB debugging must be enabled.

Regarding your problem, I briefly looked for same or similar, excluding Samsung and found

LGV20, Wayteq xTab100qcr and Glass.

I'm quite interested in this issue, though never worked with Sony, so specifics of their devices are unknown to me.

Try with volume- or volume+ button combinations for entering fastboot mode.

If that doesn't help, look at this.

I remembered I actually had contact with Sony device - it had some sort of custom FRP - my Xperia Theft Protection (MXTP) - but haven't worked with it. I planned to use Xperia FlashTool.

From Xperia FlashTool you should be able to reboot to bootloader.

Please, do inform what you have done.

  • Both commands are accepted, I've read it somewhere. When I issue the command my phone is on debugging mode and OEM is unlocked. Adb drivers gives back the device but fastboot doesn't. When I use adb reboot bootloader it just shuts down, it doesn't turn back on. when I do fastboot reboot bootloader it doesn't find the device. Commented Dec 3, 2017 at 18:45
  • I tried both commands and the results were the exact same that doesn't seem to be the problem. Commented Dec 3, 2017 at 23:32
  • I tried volume- or volume- with no success. Unfortunately my phone cannot be opened without the proper tools so I'm not able to use the video solution Commented Dec 5, 2017 at 1:49
  • Just a little update, my phone has gone in bootloop since and sometimes it stops. If for any reason I shut it down the bootloop restarts and I have to wait 5-60 minutes for it to stabilize again. Once stabilized I can't use the wifi and if for some reason I'm able to, it restarts again in bootloop. I'll have to change phone soon because my data can't handle it on its own. Commented Dec 17, 2017 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .