0

I just installed TWRP and rooted my phone and tried installing Leanage OS on my Honor 8. Everything was working well after flashing TWRP and rooting the device and I could boot to the OS.

However, once I tried installing the custom ROM, everything locked and I got stuck in a boot loop. I'm sure I've done everything correctly as I have done this before on a Samsung device without problems. I tried doing an advanced wipe for everything and trying the OS again, I also tried downloading the stock ROM which didn't work because it was not the flashable zip and I'm having trouble finding one.

I tried Huawei's erecovery option but it didn't work because the recovery was unable to fetch the package (probably because Huawei moved the packages to a different link). While booting I see a warning saying that the device has been unlocked and can't be trusted and provides a link to visit (http://zh.ui.vmall.com/emotiondownload.php?mod=restore) but the link redirects me to emui.com with nothing helpful.

I have been unsuccessful in trying other ROMs because I cannot find any to download for the US version of my phone. Any ideas on what I could do?

1

Since you have a the stock ROM you should do this:

  1. From TWRP press Advanced
  2. Reboot bootloader
  3. At Fastboot mode now
  4. Connect to a Windows Computer. Assuming the computer has Minimal adb and fastboot and you already have the Universal USB drivers installed on it
  5. On the computer extract the ROM to the folder, C:\ProgramFiles\Minimal ADB And Fastboot
  6. Back to the App Minimal ADB that you have just installed and write these codes:

    fastboot oem unlock

  7. Authorize bootloader unlock from device then continue codes:

    fastboot flash boot boot.img

    fastboot flash system system.img

    fastboot flash recovery recovery.img

    fastboot flash cache cache.img

    fastboot flash data user-data.img

    fastboot reboot

The device will eventually come up again running stock ROM. But incase you want to use TWRP, Download another custom ROM and flash it via install option in TWRP after wiping the cache, data, dalvik-cache, system and it will boot running the ROM you downloaded. To me it seems the ROM you downloaded isn't compatible to your device.

Alternatively. If the device Supports SP Flash Tool. Read a guide on how to use it to flash stock ROM. Like here: I have two Stock US ROM's here based on your build number. Select one and I'll give you the link to it: This first rom located here and this second rom located here

Waiting to hear from you @Lucas

Some things you need to know though about a custom ROM, if really designed for your model, it must boot since it comes with it's own boot.img that prepares and boots the entire accompanied files. So non-booting is a sure sign of invalid ROM if you installed it the right way.

  • I do NOT have the stock ROM. What I downloaded was an update package from Huawei that requires the stock ROM already on the device. I found no flashable downloads for the stock ROM for the US version of the Honor 8. – Lucas Dec 6 '17 at 16:53
  • @Lucas I added some lines to my previous answer. Maybe if you can identify yourself which system were you on before bricking off. I can give you a direct link to download – Thally Ace Dec 7 '17 at 5:17
  • Okay, thank you! My model number is FRD-L04, so the top one. – Lucas Dec 8 '17 at 4:28
  • I have added download links for you there. If that's the answer you've been asking for. Vote up or mark as an answer. That way you'll be supportive to my answers here on this community @Lucas – Thally Ace Dec 8 '17 at 5:43
  • I tried both ROMs that you gave me, I keep getting an Error 7 in TWRP. I tried following this tutorial (forum.xda-developers.com/showthread.php?t=2522762) but there is no assert command in updater-script. I tried a different version of TWRP and it still didn't work. I did discover though that one version of TWRP does not give me the error 7 while flashing but the other did. both are unofficial versions because the official version of TWRP does not boot on my phone. Also, I couldn't get it to work with SP Flash Tool either because there is no map for scatter-loading. – Lucas Dec 11 '17 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.