0

Has anybody in this world ever succeeded rooting this device? Tried, all One Click apps, Desktop Tools, Recovery Flash:

  1. Kingroot says Not Adaptable
  2. Kingoroot says Error code 0x00...
  3. Others say try Desktop version after fail
  4. TWRP SuperSU.zip package says exiting process after judging a lot of options
  5. All desktop apps fail same way or the other

What do a person do after all these attempts?

While closely inspecting the file system in /data I found out three files: a .gz archive of stock boot.img named by the md5sum of its content .img 16MB, SuperSU.img 99MB, and SuperSU.apk 6MB. Why the hell could the developer put the files here and device never seems to use any of these files at all?

@Izzy, your suggestion about trying was a good one but i have tried all the SuperSU zips by Chainfire and all the phone ends up in this state: In fact, the phone is unlocked, TWRP says this no matter which file I use trying to root (first screenshot); additional suggestions about a special CMSuperSU also ends up with this (second screenshot; click images for larger variants):

installation progress progress CM SU

And Magisk install completes well from recovery. On boot up Magisk app shows but as a user installed app. And prompts this which becomes unsuccessful too:

Magisk install Magisk app prompt store item not found

  • @Izzy what I have done so far is. Letting Magiskv14 do it's work, flashed it and rooted the phone instantly. What I have discovered is that Magisk is not about copying files from the zip to the system, it's based on having a persistent ever-root on the phone's boot.img. This is attained by modifying the boot.img so that on every bootup of the phone, preparation of the for the file system comes with copying magisksu to /sbin alongside other files. and then initiates startup of magisk service with init.magisk.rc on the root folder, even if you delete the files, on the next boot – Thally Ace Dec 10 '17 at 17:55
  • the system is rooted again. The stock boot img I discovered is set to unroot and de-copy all superuser oriented files from the system. That's the only way to unroot it. Magisk apk also can delete itself from /data as a user app but can't when manually installed to /system. What I did. I flashed the magisk-patched boot.img to recovery partition and stock boot.imh to boot partition. So since magisk app is in system I'm not gonna lose it booting the stock boot. On normal boot no root. On recovery-initiated boot, system is rooted. Thanks a lot. You can post an answer to this thread finally. – Thally Ace Dec 10 '17 at 17:56
  • Hm, that way you've no recovery mode anymore. And just for clarification: Magisk doesn't touch the /system partition at all. What looks to you like it copying stuff there is accomplished by a transparent Overlay File System. So installing it as a system app somehow contradicts the purpose. Well, you don't expect any OTAs for the Spark maybe – but by modifying /system you've lost the chance to pass SafetyNet. – Izzy Dec 10 '17 at 18:29
  • @Izzy yeah but I have all the images backed up: boot, secro, secfg, recovery, nvram, nvdata I have also unlocked bootloader. I usually boot the stock and twrp images while I need them. I'm completely aware of the danger of that... – Thally Ace Dec 10 '17 at 18:55
  • 1
    Got you. Yeah as a point to note for those who wanna jump into something like that without taking care of stock imgs dump :) – Thally Ace Dec 10 '17 at 21:05
2

Rooting can be accomplished using Magisk (make sure not to use an old version, but that from the linked XDA thread: v14 at the time of this writing). Flashing Magisk will not modify the /system partition but rather create a modified boot image. So at boot time, Magisk gets initialized, creating an Overlay File System on top of the system structures. That way the relevant files get (re)placed transparently, the checksum of the partitions are kept (thus OTAs will not complain), while still applying the needed modifications (including MagiskSU). Another added plus is the capability of Magisk to hide root from apps which otherwise would refuse their work.

As you've learned: Do not flash another superuser package on top of that. Magisk already includes root, called MagiskSu.

I'm using Magisk on my Wilefox Swift with CyanogenOS 13 without issues – same manufacturer and OS as your Spark. As we figured, it works on both.

Magisk comes with an app called MagiskManager (which is also available separately e.g. via my F-Droid repo. This is the frontend to work with the framework, including settings for MagiskSU (i.e. where you maintain which app may use root powers) and more. So there are several Magisk modules available, similar to what you might know from Xposed – even a "systemless Xposed" can be used that way (again, I'm using this and it works fine).

For instructions, please see the linked Magisk thread at XDA. It's quite simple. To include the basics: You need a custom recovery (TWRP is recommended, and available for our Wileyfox devices). With that, and an unrooted ROM, simply flash Magisk, reboot, and you're done. You probably need to repeat this after applying OTAs. As the MagiskManager is installed as an user app, its data are kept unless you perform a factory reset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.