0

i recently updated lineage os to 14.1-20171206 on my LG g3s (jagnm) and there are several issues:

1) can't connect to wifi. Apparently it's because wifi mac address got switched to all zeroes (00:00:00:00:00:00) i found somewhere that ifconfig wlan0 down should fix this but it doesn't work, mac stays the same.

another possible solution i found was this https://forum.xda-developers.com/showpost.php?p=70109272&postcount=5

in short:

Make an img of dev/block/bootdevice/by-name/misc
Edit it in a hex editor (details in the link)
Overwrite misc with the img
Reboot

there is just one 'small' problem: dev/block/bootdevice folder doesn't even exist. I'm at my wits end. I would appreciate any help.

2) another small problem: for some reason if i connect my device to pc or my laptop and choose on the device to use usb to transfer files it almost instantly makes my computer to crash into BSOD.

stop code: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED what failed: lgandnetmodem64.sys

PS: if it's not obvious already i'm a complete noob at command line and shell

EDIT: installed 6.0.1 resurrection rom. The mac issue persists.

ALso the PC crashing got worse. With lineage at least i could connect to adb, but now if debugging is enabled pc crashes instantly when i plug in the usb. Even though i have very little experience with stuff like this i can guess that the issue is deeper than the rom itself. Also something might be bad with LG usb drivers

0

Root your phone, install Mac Changer from Here and solve that issue ASAP

  • ok i'll try but i sincerely doubt this will work – Yokubasu Dec 8 '17 at 18:16
  • Good luck in that – Thally Ace Dec 8 '17 at 18:30
  • i found an apk, transfered it to an sd card, inserted it to my phone and installed that app. Every time i launch it (it doesn't even open) the phone crashes and reboots. – Yokubasu Dec 8 '17 at 19:24
  • Have you tried other mac changers available on play store – Thally Ace Dec 8 '17 at 22:32
  • to be honest not really. Though i tried something called busybox. It sort of let me change my mac address. But i still couldn't connect to wifi. – Yokubasu Dec 9 '17 at 7:51
0

For anyone finding this question with the same problem, I had to upgrade the firmware on my Xiaomi Poco F1 to version 10 (beryllium-V10.3.5.0.PEJMIXM-9.0-vendor-firmware.zip). It was not exactly the same issue; my mac address was 02:00:00:00:00:00.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.