2

I have both a Samsung Galaxy S4 and an S5, as well as a Samsung Galaxy Note II and an Acer Iconia tablet, and I'm having the same issue on ALL FOUR DEVICES: whether I click the cue card "Set up Voice Match" via the Google Home app, or whether I go to the Google Now app's Settings | Voice menu and click on "OK Google detection" and choose "From any screen", either way, when the next screen appears to train the phone to recognize my voice it just sits there spinning a little circular progress icon with the words "Listening..." and never quite progressing past that even though I repeat the words "OK Google" loud and clear!

Something else I've noticed is that at times I get a small toast notification near the bottom of the screen saying, "Trouble with the microphone, please try again in a few seconds."

Has anyone had this issue and resolved it successfully?

Here's what I've already tried:

  • Rebooting
  • Disabling Samsung S-Voice (both via its settings and also freezing it using Titanium Backup)
  • Switching from WIFI to mobile data
  • Updating both Google Now and Google Home

None of the above has helped the situation any. There was a time where this worked just fine, but I can't tell when it stopped because it's been a while since I went back to it. Please help! Thanks.

  • Im having the same issue with an s4 with google home. Please update this post if you have any progress – JRowan Jan 29 '18 at 22:27
  • I've been following the topic on the Google Home Help Forum at productforums.google.com/forum/#!topic/googlehome/… and some people have apparently gotten over the issue but many others haven't. You can read their experiences and see if any of the fixes apply to you. So far nothing has helped me. – ShieldOfSalvation Feb 3 '18 at 16:29
0

What ultimately cleared this issue for me was turning OFF the Accessibility Service (in Android Settings) for my Samsung Level U Pro Bluetooth headset. I learned this after resetting my phone back to factory settings and seeing that voice retraining for Google Home and the Google app all worked fine initially after the reset, and then stopped working after I had set the Samsung Level app to give me voice notifications over my Bluetooth headset. That last act apparently set an Accessibility Service for the app to ON, which seems to conflict with Google's ability to hear my voice when I'm training it to respond to, "OK Google".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.