0

In Oreo, every time the message entry field in Google's Messages app receives focus, it immediately pops up an annoying "autofill" suggestion listing my phone numbers. (I use a dual-SIM phone, so it lists two numbers in my case).

Apparently "Autofill with Google" service believes for some reason that message entry field in Messages is somehow intended for entering phone numbers. This does not make any sense, of course.

Is there any existing workaround for this bug? Does it behave the same way in single-SIM phones?

enter image description here

  • Were you able to solve this? I have the same issue, and it's very annoying... Updated to Android 9, but this bug is still there... Thanks! – Slash Nov 16 '18 at 22:02
0

This isn't a bug. People use to enter phone numbers too while sending messages sometimes that's why it pops up as per me. I use single sim card and this does not pops up here. Worth to mention that I use beta version of Google app. You can turn the service off. Go to Settings/System/Languages & input. Tap the Advanced tab to reveal more options. Now choose Autofill service and select "none".

  • 1
    Yes, this is a bug. People enter many things, like their names and birthdays. However, this is not an excuse to pop up this information for every text entry field. Phone numbers are supposed to pop up only for the fields that are explicitly marked as fields intended for entering current user's phone number. That's how Autofill works. That's how Autofill has always worked. In this case we observe a bug, either in Autofill or in Messages. – AnT Dec 14 '17 at 19:23
  • And no, I don't want to disable Autofill service entirely: I want it to autofill passwords for me. – AnT Dec 14 '17 at 19:25
  • I supposed that may be a bug then. Why don't you try updating Google app to beta to see if bug is fixed? I am using beta it doesn't happens with me. – Impulse Dec 15 '17 at 13:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.