3

Suppose the bootloader of an Android device is locked.

Is there any way to install a custom ROM without unlocking the bootloader? If yes, then how?

  • 1
    It depends on the ROM you are trying to flash. If it is based on the stock kernel, then it is possible. But it's difficult to give a universal answer - it depends on your device, the security aspects but into it and the ROM you want to flash. Best is to search the XDA forums for your device and see if such a ROM exists for your device Such devices are few and most devices require bootloader to be unlocked and custom recovery installed to be able to flash a custom ROM – beeshyams Dec 21 '17 at 8:52
  • 5
    Specifying your device and Android version will help you get good response – beeshyams Dec 21 '17 at 8:53
  • Just download sp flash tools. Turn phone off and flash whatever you want... – Sura Beily Jun 17 at 12:01
0

Yes, however, this method will not work on every phone.

Prerequisites

  • Back up all data on your phone
  • Unknown sources enabled in security settings
  • Being prepared to void warranty.

Method

  1. Download and install an on-device one-click-root root-management application on your phone (notable mentions include Kingo Root and Kingroot, both personally tried and tested to work)
  2. Use the application to root your phone and gain root access.
  3. Download and install an on-device partition-flashing application. (notable mentions include Rashr, Flashify or even the official TWRP app)
  4. Download a custom recovery for your device (TWRP recommended, see here)
  5. Use the app you downloaded to flash the recovery file you downloaded.
  6. Reboot into recovery (device-specific)
  7. Install any custom ROM you want

You are now rooted and have a custom recovery installed; this is an enormous security risk, especially since anyone can delete your lockscreen password from recovery mode and hence have full access to your device.

If you brick your phone you will have a very hard time getting out of such a situation because your bootloader is locked.

I have personally tried this method before on a Nexus 5 running and Lollipop 5.1.1 LMY48M and it worked.

I would recommend going the "old-fashioned" way to root your device and unlock your bootloader.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.