0

I've got a 2012 wifi Nexus 7 tablet. The battery will not charge much above approximately 20 percent. I've installed a new battery, tried charging using a nice Anker brand usb cable, tried several different good chargers, replaced the little usb/audio jack wiring harness, cleared the cache, as well as tried charging after shutting down from the OS then holding volume down button when powering up the selecting "power off" from the broken android window. Other suggestions? This is a nice little device that I still have uses for. Thanks in advance...

Update: OS is Lineage 14.1 20171112

  • Thanks for the detailed response. I have been wiping regular and Dalvik cache using TWRP. Hadn't tried this in safe mode. I'll google SM, try it and report back. Note this problem was present with the previous battery running one of the last CM releases for this unit, not sure that the wipe and reinstall that I did to w/Lineage had any effect on this issue. I'd assumed that this was a battery problem. – portsample Dec 24 '17 at 6:42
  • I'm thinking that most if not all "new" batteries for sale having been in a warehouse for years and may be degraded. This is actually the second "new" battery that I've bought trying to solve this problem. Performance and runtime appear normal for the percent remaining in the battery as shown both by the AndroidOS icon in the toolbar AND percent shown when in TWRP in upper right. Thanks for your help w/this Beeshyams! – portsample Dec 24 '17 at 19:21
  • Tablet was plugged in all night. Currently the tablet is booted into the OS, plugged into a charger and showing 4% with the "lightening bolt" in the battery icon indicating that it is charging. Typically now the battery level will drop to 3%...then 2% and the tablet will shutdown. Bluetooth + Wifi are both off, and the device goes to sleep after 30 secs to conserve power. – portsample Dec 24 '17 at 19:38
  • Let us continue this discussion in chat. – beeshyams Dec 24 '17 at 23:26
  • @beeshyams you get the prize! Ordered a replacement battery from the vendor that was "newer" than the previous one he shipped. This battery showed 60% when initially installed in my Nexus 7. Shut the tablet down, plugged into external AC overnight, and the battery level in the morning was still at 60% charge. I've just downgraded the OS from Lineage 14.1 20171112 to AOSP_grouper-ota-eng-20151229, (Android M, 6.01). After 2hrs plugged into AC the battery is at 87% and appears to be charging normal. Most curious given that I ran this thing for months on Lineage 14.1 w/no charging issues. – portsample Jan 18 '18 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.