2

When I connect my phone to my computer, no files are found on the device. It says this folder is empty. This is a new unlocked phone running Nougat 7.1.1 and this is the first time I've connected it to my PC. I've tried turning on USB-debugging but nothing changes. Is there a way to fix this?

UPDATE: I fixed the problem by changing USB configuration to PTP (picture transfer protocol), then back to MTP (media transfer protocol. Thanks for all your help!

  • 2
    Did you pull down the notification shade and choose MTP instead of Charging Only? – Andy Yan Dec 27 '17 at 12:41
  • yes, ive tried almost all usb modes – Jacob M. Dec 27 '17 at 16:59
  • 1
    This is commonly because the External Storage and Media Storage databases are out of sync and MTP mode doesn't allow for direct file access or listing, it relies on the database... Disconnect all USB cables, go to Settings - Apps - Show System and find Media Storage and External Storage and perform a Clear Data on both of them, then reboot. After the phone is completely booted, wait about 5-10 minutes and reconnect USB and go into MTP mode and see if the files now show up. – acejavelin Dec 27 '17 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.