0

I have a THL T9 Plus with Android 6.0. Google Play Store version is 8.5.39.W-all [PR]. Google Play Services is version 11.9.51. I try to install updates on phone, but I get the error message, "There was an error during update process." I can't see even new version of installed applications in the list.

I tried to force stop those processes, wipe caches, restart phone and I already updated Google Play Store client version, but none of these helped, I got same error message.

1
+50

Here are list of things can be done like uninstall updates and install fresh again, you can get a list of check here

  • Yes, fresh install seems a good solution, but where to found proper apk file? – plaidshirt Jan 18 '18 at 11:52
  • It is a system app ; you can't uninstall or install. What you can do is to uninstall updates by Settings > Apps > Google Play Store and tap on “Uninstall updates”. Connect to Wi-Fi and your updates will be installed automatically – beeshyams Jan 18 '18 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.