I can start a conversation in Google Messages to an e-mail address. When I send the message, it appears to go through an SMS to e-mail gateway, and I (or whoever owns that e-mail address) can in fact reply to the e-mail and it gets routed back through the gateway and I receive an SMS.

This all works well and good, but the e-mail address is random letters and numbers and I want a nice description instead of that. So I created a contact for the address. However, now I can't send a message because Messages doesn't find the name when I search for it. Oddly enough, if I happen to remember the entire e-mail address and type it in up to the "@" character, suddenly it "happens" to remember that there is a contact with that name and lets me select it. However, this is pretty much useless when I have to remember a 12+ character string of random numbers and letters to get an auto-complete!

How do I get the contact to show up to send an SMS when it is only an e-mail address? I have tried editing the contact and pasting the e-mail address as a phone number, but it strips out all the non-numeric characters this way.

  • If you are downvoting, could you please leave a comment on how I could improve the question?
    – Michael
    Dec 28, 2017 at 23:26
  • 1
    it was probably downvoted by someone who didnt bother reading your question. They probably read the title and voted right away. +1 for the good question
    – aBochur
    Dec 29, 2017 at 0:25
  • Did you find a workaround?
    – aBochur
    Feb 11, 2018 at 22:06
  • @ABochur No, I wound up having to type the whole random string of characters manually.
    – Michael
    Feb 12, 2018 at 23:44

1 Answer 1


I just tested the issue with a few different messaging apps, and I came to the conclusion that the app was simply not made to do that. In both Google messages and textra, I had the issue you describe, but as soon as I tried it in Samsung's messaging app it worked perfectly. As soon as I started typing the name, it gave me the email address as an option.

That's why I conclude that Google messages was strangely not made to do what you are looking for.

As a workaround, I suggest that you text the person once, and then every time you want to text them again, instead of initiating a new message, simply press on the search icon on the top right of the screen and type in the name of the contact, press on the contact, and you have achieved the same thing as you wanted with ease.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .