I attempted to root my Amazon Kindle. That seemed to go well, but when I tried to add the Google App Market, I apparently made a big booboo, because now I am in "constant reboot, 'kindle fire' screen of death". That is, the fire won't boot, and it just stares at me with "kindle fire".

I've googled around, and found people with my exact problem, but no way to fix it. And my problem is this:

The permissions on my /system/app folder are as follows?

d--------- root     root              2012-01-28 13:26 app

Yeah, I know, not good.

So, how can I fix it? I've tried the various methods out there, but basically, because the directory is so hosed on permissions, I can't do anything. For instance, I can't run

mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system

because I get

mount: Operation not permitted 

and when I try

adb root

I get the cryptic

adbd cannot run as root in production builds

So I am dead in the water.

Can anyone help me fix my permissions on /system/app?

  • 3
    Do you have a custom recovery and/or bootloader installed? If not then you may be stuck unless you can make yourself a "factory cable" (or find one made by someone else). – eldarerathis Jan 29 '12 at 7:16
  • 1
    Agreed with eldarerathis. The cable may also be called a "jig". – Matthew Read Jan 29 '12 at 17:35
  • Actually, another important factor is what firmware version you have. If you have 6.2.1 or lower you may be able to use adb to get into fastboot. – eldarerathis Jan 29 '12 at 18:22
  • Wow -- thanks for the tip about "Factory Cables". Interesting stuff. – Nick Hodges Jan 30 '12 at 23:28
  • 1
    Amazon is graciously sending me a new one, and I'm sure when I return mine they will be using a factory cable to reset it. But I have 30 days to return it, so I may take the time to try to build a factory cable myself just for the experience. – Nick Hodges Jan 31 '12 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.