0

I'm trying to backup using adb backup org.mozilla.firefox on a Nokia 8 (with Android 8.0).

I get the screen where it asks for a password. There are two texts at the bottom "Cancel" and "Backup my Data". They look identical (i.e. it looks as if I can click either) but nothing happens when I press "Backup my Data". What is going on?

I also tried to enter a password but that doesn't help.

Same effect with adb backup -apk org.mozilla.firefox: in both cases, only an empty backup.ab file is created. To be sure, I've also included the -f option to explicitly specify an output file name – same effect, the file stays empty.

adb version 1.0.39.

  • Not sure if it's mandatory, but didn't you miss the -f <filename> parameter to tell ADB where to store the backup to? – Izzy Dec 30 '17 at 0:08
  • Without that, it defaults to backup.ab. I can see that an empty file is created. Just to be safe, I also tried with the parameter. Same effect. – Aaron Digulla Dec 30 '17 at 10:17
  • Thanks, Aaron! Just wanted to be sure, as you mentioned neither (even not the empty file). Wouldn't be the first time some device came with a strange ADB daemon. In my case with one device (no longer in use), adb backup worked fine but adb restore did nothing. So it could be a faulty ADB daemon as well. Have you tried with other apps? It might well be Firefox having backup disabled (ALLOW_BACKUP:FALSE). Otherwise, while waiting for answers here, I'd suggest you try contacting Nokia's customer service. – Izzy Dec 30 '17 at 13:20
0

Mozilla disabled backups back in 2015, documented in Bugzilla.

Of course this causes a lot of trouble for people trying to get access to their own data.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.