1

I have a a10 tab 2 lenovo. I recently reflashed the original new rom. Before everything was working except the wifi was slow(lots of lag) which was on a hacked rom for some similar tab.

The problem I have now is that when I turn on the device for the first time, the main wifi network is not found nor loaded. It either takes a few minutes or I have to simply open the wifi settings in which it then finds and connects to it. It ends up connecting to a more remote network which is too slow to use.

My phone is connected to the same networks and it finds and uses the correct network immediately without issue as did the tablet before I changed roms.

I'm not sure if the tablet thinks that the first network it connects to is better(sometimes I use it, but rarely, only when I'm take it to the other side of the house) or what. It seems it is the tablet. I'd basically want it to always use the main network A(which is 100% signal strength) rather than the 50% strength of network B that it connects to(which is on the other side of the house).

any ideas why this is doing that and how to change it? Basically I want it to connect to network A. I suppose I could forget network B and it might do it but then I'd have to remember the wifi pass to it and enter it in every time and have it forget every time... just to fix a problem that shouldn't exist in the first place.

I'm pretty sure it must be a setting/configuration on the tab since it was working before the rom change and my phone works fine which has identical wifi setup, locations, etc.

It is android 6 rooted.

[The problem is that when I turn on the device, go to a browser I get wifi error. I open the wifi settings, it connects without me telling it which network. I have to clear the browser so it stops using the old wifi network, then everything works]

  • Try this app - you can specify the connection order – beeshyams Dec 30 '17 at 11:22
  • @beeshyams I'd rather not install an app. Surely there is some config file that can be modified or settings that do not require some app to run constantly for a temporary thing. – AbstractDissonance Dec 30 '17 at 11:34
  • I understand. That rules out automation option to disconnect on connection to the undesired WiFi. See if enabling Always allow WiFi Roam scans in developer options helps- a guess – beeshyams Dec 30 '17 at 11:39
  • 1
    Also, the other wifi in my house is on the same channel. I'll try to change the channel when I get a chance and maybe that will solve it. It doesn't seem like it should be the problem since the main one is about -40dB while the other is -72dB(11 times less powerful). – AbstractDissonance Dec 31 '17 at 8:09
  • 1
    @Izzy Ok, I made the SSID non-hidden and it now connects like it's suppose to. I noticed that the channel was 11instead of 6 so that might had something to do with it, but it was automatic. This router runs in bridged mode and I'm not sure if it uses the same ch as the main router, but it always looks to use it. This might be the problem though since the other router might think ch 6 is good where it is at but it's not good where the bridged one is. In any case, it still has to be an issue with the device ultimately because my phone has no issues either way. – AbstractDissonance Jan 2 '18 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.