Okay, so I've figured out how to set up ADB on Mac OS X and I've followed all the instructions on how to get to Fastboot from ADB. The last command I use is:

fastboot oem unlock

This command in ADB is supposed to unlock the bootloader. On my device, it asked for confirmation to unlock the bootloader, volume up is yes and volume down is no. Well, the "no" option works perfectly fine but then the "yes" option does absolutely nothing on the device or the terminal window.

Does somebody know what's going on? I can seem to figure it out, even though I've searched all over the internet.

Some sites say that you have to take the device off of the charging cable before booting into fastboot, but I've tried this and found it unsuccessful.

My device is running Android Lollipop. All the developer settings are enabled like they're supposed to and ADB commands all work until the point where I get stuck.

EDIT: I'm attaching a screenshot of what my developer settings page looks like. I can't find the OEM setting anywhere.Image

  • In developer options, have you enabled "allow oem unlock"? Also, have you seen the XDA guide on RCA Voyager RCT6873W42 Unlock Boot loader and root? As you only say "all the instructions" but not which ones, it's hard to guess.
    – Izzy
    Dec 31, 2017 at 22:27
  • I have already checked that page, however, the ADB terminal code was invalid when I typed it in. They used something like "fastboot flashing unlock" which just showed an error in the terminal window. I've been using forums.oneplus.net/threads/… for the process. I've checked the developer options, however, "oem unlock" doesn't seem to be an option at all.
    – 8380716
    Dec 31, 2017 at 22:32
  • The fastboot flashing command is e.g. used on Verizon devices. OK, I have neither, so I am out here. Just thought to mention the XDA post; couldn't know you'd already seen that.
    – Izzy
    Dec 31, 2017 at 22:41
  • Thanks I appreciate your help. I was going to follow that XDA post, but it seems the links to the downloads on it no longer even work :/ Oh well, hopefully someone can help me out or I'll con across a solution I haven't found yet online.
    – 8380716
    Dec 31, 2017 at 22:58

2 Answers 2


Do you have the USB DEBUGGING CHECKED BOX ON. I know USB DEBUGGER has to be on. Theres also a box about ADB/ADT make sure that is checked along with the setting install from unknown locations has to be on for 3rd party apps other than the ones from google play. It sounds like that is all that has to be on in your settings under Accessibility and under Developer options in your Settings menu. Your other question about your volume up and down button. You need to shut your phone off then hold down on volume button and power button at same time until you see the Android bootloader settings pop up on screen then let go, somme samsungs you also have to be holding down on the menu key as well as power key, volume down.all at same time till bootoader then hurry let up

  • I'm not having an issue entering fastboot. But when it asked to confirm unlocking the bootloader the volume up key doesn't work, which is the button you need to press yes to confirm.
    – 8380716
    Jan 7, 2018 at 20:51
  • It should be the VOL UP but you may want to try the VOL DOWN as weel I remember on another RCA device that people having that problem that it only worked with the VOL DOWN. By the way which version of Android does you device run? Were you able to turn on OEM unlocking in developer Settings?
    – Sruly
    Jan 15, 2019 at 22:48

I remember seeing others having the same problem.

One of the solutions I have found that worked is to hold down the the Vol up while you enter the command on you PC and hit enter. Then when release the VOL UP and press the POWER button.

You may want to go thru the following 2 threads on XDA Forums From what I remember there were some other solutions to your problem there.

The above solution I found in the middle of post #103 (its a long post and the poster first says he wasn't able to get it and then edited the post with this solution).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .