3

I had ADB working just a few days ago, but now, whenever I try to run adb.exe, it will start the daemon successfully, and then after a couple of commands the adb.exe file itself will disappear. When I try to uninstall then reinstall platform-tools via Android Studio's SDK manager immediately afterward, the uninstaller hangs (though the window doesn't freeze) after the following output:

To install: Preparing "Uninstall Android SDK Platform-Tools (revision: 27.0.1)". Generating patch... "Uninstall Android SDK Platform-Tools (revision: 27.0.1)" ready. Finishing "Uninstall Android SDK Platform-Tools (revision: 27.0.1)" Stopping ADB...

with the status:

Packing .installer/

However, I can't seem to find anything ADB-related in Task Manager. I tried killing it with adb kill-server, buy CMD's reply was of course that it couldn't find adb. After I restart Windows, the uninstallation/reinstallation runs perfectly well, but ADB just disappears all over again. What in the world is going on, and how do I get ABD up and running again?

Example CMD. When I reinstalled ADB after taking this screenshot and tried again, I didn't even get the * daemon started successfully message.

My CMD output

OS: Windows 10

Device: LG V30+ (United States/Sprint), Android 7.1.1, LGE USB driver

5
  • 1
    Sometimes Antivirus softwares block ADB, try disabling your AV software and try again. Or download Minimal ADB& Fastboot.
    – esQmo_
    Jan 2, 2018 at 2:41
  • Facepalm. Yep, that was it. I checked my quarantine folder and it was full of adb.exe's. Thanks.
    – Matt
    Jan 2, 2018 at 2:43
  • You're welcome. I never understood why ADB os blocked by AV softwares.
    – esQmo_
    Jan 2, 2018 at 3:03
  • AV software often has more side-effects than good uses. Glad I don't need that snake-oil which only eats resources, throws false alerts, and makes things disappear :)
    – Izzy
    Jan 2, 2018 at 9:06
  • 1
    Unless you are on Linux systems, AV is mandatory for Windows computers, or at least essential, as they are mainly targeted by malwares and viruses
    – esQmo_
    Jan 4, 2018 at 3:34

2 Answers 2

4

As esQmo_ guessed in the comments on my question, my antivirus (Avast) was blocking adb.exe, probably with some silly "heuristic protection" feature. I checked my quarantine folder and found it chock full of adb.exe's. I whitelisted adb.exe and did not run into any more problems.

-1

That's all true. Disable Avast for Adv. exe but it seems to be a real threat because when trying to install the APK on a real device, the antivirus of the cell blocks it. If we unlock this option, we see strange behaviors in the Android system so I'm convinced that "Adv. exe " comes with bad intentions from a download server in Android Studio.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .