For a few days now, I've been trying to recover my phone. It's a XT1069 (a brazilian dual-SIM Moto G 2014 with 16 GB of storage and DTV). It had a Resurrection Remix ROM with Android 7.1. The battery died, and then whenever I tried to turn it on, it got stuck in Resurrection Remix's loading screen, for whatever reason. That wasn't really a big issue, in fact it was actually good, because it gave me motive to update my ROM, which I was planning to do.

Up until then, everything was working fine (although Resurrection Remix didn't boot). I downloaded Pixel Experience with Android 8.0, then I opened TWRP and transferred it to the phone through USB (TWRP supports it). I wiped the system partition (don't remember why - maybe I had tried to install it before and got an error, maybe out of space, I don't know) and tried to flash it. It gave an error, which basically meant I had to update TWRP.

But uh oh! I can't anymore. My PC won't detect the phone whatsoever! I tried using fastboot, ADB in TWRP, MTP in TWRP, but all I can do via USB is charge it (TWRP does display a "+" after the battery percentage, and it does charge). I was using Debian 9.0.0 when I did this, but I accidentally deleted all partitions in my HDD while trying to install Windows 10, managed to recover them, and finally actually installed Windows 10 (for dual boot - I couldn't dislike Windows more). In either Debian or Windows, it doesn't detect it anymore. Previously it would make a sound and display a notification. It doesn't anymore, in the same conditions (in TWRP, with MTP either enabled or disabled). ADB and Fastboot don't work at all, where they previously did. I already installed drivers in both OSes. Actually, before I even installed drivers, it worked. Even the SD card isn't being detected by the phone anymore. It doesn't mount in TWRP (no error, it seems it wasn't even inserted), and I can't access it in the Install menu (says it's 0 MB, and won't access it). It previously worked.

I've searched around a ton. Every solution is basically installing drivers, using MTP (can't do), disabling MTP to use ADB (can't do), using ADB Sideload from the Advanced menu in TWRP (can't do), restarting computer and/or phone, updating TWRP (can't do), SD card (can't do), USB OTG (I don't have an adapter, and buying one would require my parents' consent, which is a bad thing, and besides, considering the other options, it's not likely that it'll work).

I'm desperated. I don't know what to do anymore. Can somebody help me? What can I do to update TWRP, while my phone is in this state?

(Large question, eh. Well, I'm being as specific as I can. Please read it so you can understand the situation.)

  • Is your ADB for windows the latest version? I have heard on XDA that older versions can create a problem just a guess
    – beeshyams
    Jan 2, 2018 at 4:57
  • It was an old version, and I updated, no dice though.
    – jv110
    Jan 2, 2018 at 22:26

2 Answers 2


I have had this exact problem with an XT1039. As you've deleted the system partition you'll need to restore to a factory ROM for the phone, which is on XDA. Boot to recovery (power + volume down), and plug the phone in to your PC and you should have access to a minimal adb. Flash the factory image and it should then boot.

These instructions should help: https://forum.xda-developers.com/showthread.php?t=2542219

  • The biggest problem OP have right now is exactly the PC not detecting the device at all.
    – Andy Yan
    Jan 2, 2018 at 9:19
  • True, but they don't seem to have booted to recovery, which is probably the only thing that's going to work - the issue is probably that system folder was deleted. Jan 2, 2018 at 9:47
  • Recovery ≠ bootloader - recovery at most provides partial ADB support; bootloader is what works with fastboot.
    – Andy Yan
    Jan 2, 2018 at 10:03
  • Corrected, you need a method of getting the factory ROM onto the phone. I've found an XDA post now, added to the answer. Jan 2, 2018 at 10:31
  • Hmm, I don't see any reference to adb push in the thread you referred to... OP also mentioned ADB not working for him either though. For now I myself am out of ideas.
    – Andy Yan
    Jan 2, 2018 at 11:21

Seems it was a problem with my computer and my cable. I got lucky and had a chance to try with another computer and another cable, and the USB worked. Working fine now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .