2

I traveled to Japan and bought a phone there. I changed the system language but websites keep showing in Japanese in Google Chrome, twitter.com for example.

Firefox is fine though so it seems like the issue is solely with Chrome. I tried completely removing and reinstalling Chrome but that did not fix the issue.

  • Chrome Type Chrome://flags and enable (instead of default) Translate language by ulp and use new language header . See if that helps – beeshyams Jan 3 '18 at 3:28
  • 1
    Tried both separately and together and it didn't help, sorry. – Asik Jan 3 '18 at 17:04
  • It was a guess anyway, better luck – beeshyams Jan 3 '18 at 17:06
0

Usually websites that you visit will be in the language that they were made in.

My guess is that Google results in your browser are showing in Japanese and you're looking to change that.

To do so, go to Google.com then scroll down to the bottom of the page. There, press on "settings" -> "search settings" -> "language in Google products" -> English (or any desired language)

Also change "region for search results, to "current region" as shown in the screenshots below.

enter image description here

enter image description here

  • This is not about google search results. Websites just default to Japanese, for instance twitter.com. – Asik Jan 2 '18 at 22:47
  • @Asik try the same websites in incognito mode. Let me know if it's still in Japanese – aBochur Jan 2 '18 at 23:04
  • Yes, in incognito mode websites default to Japanese. I think it's to do with the Accept-Language header sent by the browser. – Asik Jan 3 '18 at 1:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.