When opening Chrome browser on Android (brand new Pixel 2 XL with no root or customization and with all latest updates), it goes to a cluttered page with the Google logo and a bunch of nonsense I'll never use. How do I get this to be BLANK when I open it, and that goes for new tabs as well?

4 Answers 4


Doesn't seem to be anyone out there who can answer this, so I'll post my workaround. Make a home screen shortcut to "about:blank". Using the Nova launcher, you can change the name to "Chrome" and the icon to be identical, and just use that to launch the app.

Unfortunately it still doesn't do anything for new tabs though. I mainly use Adblock Plus browser because Chrome is ridiculously notorious for pushing Google content, and will continue to do so until they add more options for control.


You can use kiwi browser and install Automa extension


Here's how to set it so that when you open chrome, it should go to a blank page.

Open chrome, press on the three dots found in the top right of the screen, go to 'settings' then, click on 'home page' enable the home page option, and change the home page URL to about:blank just that, no www or anything.

This way, when you open chrome and you don't have previously opens tabs, you will get a blank page instead of the default one.

According to AndroidPolice there is no way to have the new tab open in a blank page, but he does mention some workarounds that might suit you.

  • 2
    There is no "home page" under settings.
    – R-D
    Jan 5, 2018 at 21:10
  • @BuddyZ just found that the home page option is not available in pixel phones!!? reddit.com/r/GooglePixel/comments/5d6f2z/… really not sure why it wouldn't be there.
    – aBochur
    Jan 5, 2018 at 21:16

I finally figured it out. Even if you have the default website set, when you open Chrome, it gets stuck on another website that opens up.

  • If you open Chrome, you have to hit the "house shaped" button on the upper left and that will take you to the home page.
  • In order to get your Chrome to open to the home page, you need to delete all of your tabs. To do this, make sure you are on the home page, and then click on the box on the upper right side. There should be a number in that box, that is the number of tabs open.
  • Then click on the hamburger symbol (a line of 3 dots on the upper right) and you will see "close all tabs". You will only see this after clicking the tab box first and then clicking the 3 dots.
  • Now your Chrome will open to your default home page.

I was racking my brain trying to figure how why it wouldn't open to default. It's the multiple tabs open!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .