1

I am trying to install the Android Terminal Emulator by Jack Palevich (https://github.com/jackpal/Android-Terminal-Emulator)

I have tried installing various versions of this application, including this fork: https://github.com/dvhh/Android-Terminal-Emulator

I am unable to install the application on my Android device running kernel version 3.10.49 (jenkins@80b25755b68d #1 Fri Aug 18 23:17:19 JST 2017)

When running from the device, I get an error saying installation from unknown sources is forbidden (even though unknown sources are enabled in the settings)

Installation through adb reveals the real error:

>adb install C:\term-release.apk
C:\term-release.apk: 1 file pushed. 2.7 MB/s (572662 bytes in 0.199s)
        pkg: /data/local/tmp/term-release.apk
Failure [INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES]

Device is a Kyocera DuraXE flip phone.

I have Googled this error and tried every solution I found.

  • I cannot uninstall and reinstall the app because the app is not installed to begin with

  • I have made sure unknown sources are enabled

  • I have tried rebooting the device

  • There are no "overlays" running on the device that I am aware of. It's a brand-new phone fresh from factory.

I'm at a complete loss as to what to do. I have also tried installing alternate software like termux but I get the same errors every time.

I tried running it on the device from Android Studio as well. Here is the result:

01/05 12:49:12: Launching Term
$ adb push C:\Users\myusername\ApkProjects\Term\Term.apk /data/local/tmp/jackpal.androidterm
$ adb shell pm install -t -r "/data/local/tmp/jackpal.androidterm"
    pkg: /data/local/tmp/jackpal.androidterm
Failure [INSTALL_PARSE_FAILED_INCONSISTENT_CERTIFICATES]


$ adb shell pm uninstall jackpal.androidterm
DELETE_FAILED_INTERNAL_ERROR
Error while Installing APK

It gives me a pop up saying there was an error installing and to try uninstalling the package, but when I click OK i get "DELETE_FAILED_INTERNAL_ERROR", probably because the app isn't actually installed.

At a complete loss what to do

unknown sources enabled

install blocked

  • So just an update, it appears that this particular model of phone comes with a custom version of Android that Kyocera have basically restricted installation of all 3rd party apps on. I don't know of any way to bypass this restriction. If anyone does, please let me know. – ag415 May 7 '18 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.