1

My phone Mi A1 showed first the notification update for Oreo, it failed twice before showing the update for Security Patch of December after which the update of Oreo totally disappeared. Checking for the update manually the phone shows the message that I am on latest update. I tried the available online solutions of:

  1. Reset Factory Defaults.
  2. Clear data of Google Services Framework followed by a Disable then Enable.

None of them worked!

1

I have the same device and this may help

  • There were two December updates for Nougat. You need to have 7.12.19 which is a prerequisite. My son also purchased the device a week after mine and he got the second update just yesterday and no Oreo yet, so I suspect that the roll out in batches is linked to the purchase date

  • Clearing Google services framework is not recommended but I went ahead and did it, since none of the users who did it reported any problems. Update didn't follow immediately but it came after about 7 hours (overnight)

  • Some users have successfully got updated after spoofing their location to other countries, using a VPN (US and Germany). I did this too but didn't work

Of course the fastest would be to visit local service centre and get it done free of cost

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.