I've tried multiple times to flash ClockworkMod recovery onto my unlocked Galaxy Nexus (LTE\CDMA variant "toro" build) device. Each time I can boot into recovery and ClockworkMod displays. However, if I completely reboot my device (boot into Android and then reboot), when I try to run recovery, my phone shows an android with a red exclamation point and refuses to boot. I've tried flashing from both Linux with the fastboot tool as well on the device itself with ROM Manager. ROM Manager reports that ClockworkMod is flashed.

What am I doing wrong?


1 Answer 1


I had the same problem and I found the solution is to rename a file in the system folder:

  • remount /system in read/write mode (use something like the Root Explorer app or ES File Explorer; both have root modes (check the app's settings) for remounting /system as writable)

  • rename the /system/recovery-from-boot.p to /system/recovery-from-boot.p-bak

(note: you could delete it, but renaming is much safer since its easily reversible)

you could also do this manually in an adb shell or on-phone Terminal session:

  • mv /system/recovery-from-boot.p /system/recovery-from-boot.p-bak

  • after you've renamed the file, you might have to re-flash your CWM if it had been missing previously


  • The logic here is that flashing a known working recovery every boot reportedly keeps the phone operational. shrug
    – Broam
    Feb 2, 2012 at 13:57
  • 1
    The problem is that once you have flashed CWM recovery, the recovery-from-boot does not actually work, so you can't boot into recovery at all, you just get the annoying red triangle of doom.
    – Malachi
    Feb 2, 2012 at 15:02
  • 1
    The so-called "annoying red triangle of doom" is the stock recovery. In older versions you could enter the stock recovery menu using volume-up + power. Post-ICS the stock recovery doesn't have much that it can do, and later devices and versions have a "dumb" version that requires external commands or instructions from an OTA, without any manual on-device interaction possible.
    – Greg
    Aug 22, 2013 at 23:48
  • @greg in other words you need adb to handle the old-style stock recovery? and is this only with the stock nexus ROM or do all ROMs (including community ones) do this irksome auto-flash-recovery-on-boot?
    – jiggunjer
    Nov 3, 2015 at 2:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .