I recently purchased a tablet that is a cheap allwinner a33 based Chinese product. I wanted to connect to it over adb but the RSA key popup would not come up.

The build.prop shows the ro.adb.secure=0 which should mean that the device requires no rsa authentication but my Windows 10 machine still shows the device as unauthorized.

How do I get the device authorized so I can use adb?

I have no root access and would need adb to root.

  • Does it show in device manager? Did you install adb drivers? Also enable developer options in settings.
    – user248200
    Commented Jan 11, 2018 at 8:05
  • yes, yes and yes
    – Top-Bot
    Commented Jan 11, 2018 at 19:28
  • Did you try with Linux? Or is that only with Windows?
    – user248200
    Commented Jan 12, 2018 at 8:27
  • I tried with both
    – Top-Bot
    Commented Jan 12, 2018 at 12:48

1 Answer 1


I don't think ro.adb.secure is the reason why your phones shows up as unauthorized.

ro.adb.secure is a switch to allow adb to launch at boot (or not). relevant discussion.

Your problem sounds more like a local problem with your adb setup on your laptop. You should try the following steps:

  • download/install correct adb drivers for your linux/windows machine, which are released for this specific chipset (allwinner a33), possibly you won't find much, but something that is compatible hopefully
  • try lsusb (linux) to find the USB vendor/product ID for the tablet and search for compatible adb drivers
  • having the vendor and product ID you should be able to understand whether the USB mode for adb is actually enabled on the phone, i.e. if the phone runs USB with mtp,adb / ptp,adb or with just ptp etc.

example with a Moto G4 Play (msm8916):

shell@harpia:/ $ getprop sys.usb.config                                        

pi@pi:~ $ lsusb
Bus 001 Device 007: ID 22b8:2e76 Motorola PCS 
shell@harpia:/ $ getprop sys.usb.config

pi@pi:~ $ lsusb
Bus 001 Device 009: ID 22b8:2e84 Motorola PCS 

depending on the USB mode selected on the android phone, the USB product ID is different.

All that is closely related to udev rules (link to relevant discussion), although setting up or manipulating udev rules never solved my problems (and my Raspbian 9 doesn't even have the file /etc/udev/rules.d/51-android.rules).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .