I've a notification from Android system that I can only snooze, not remove permanently, about an app running in the background. It's specifically about Keepass2Android:

Keepass2Android is running in the background

I know it's running in the background so I don't need to be reminded about it constantly. Most annoying is that it takes up unnecessary space.

Is there a way to disable this notification?

2 Answers 2


I am on Oreo 8.0.0 and couldn't find a setting for this so ended up using this Hide "running in the background" Notification

I have several apps running in background and disabled them all using this app, as it serves no useful purpose for me to know

Auto Notification is another app that has this feature amongst other Tasker oriented features if you are interested.

I preferred the first one since I don't use Tasker

Edit: These are Bye the way notifications


Long press/Hold the application name is running in the background and toggle the switch available, like seen in the below screenshot (option is currently enabled, turn it off to disable the running in background notification) toggle option

Or you can go to Settings > Notifications (enable show system apps option found in menu) > Android System > Disable Apps running in background (options enabled in screenshot for viability) android system toggle

  • There's no switch available when long pressing, and the one from your second screenshot is greyed out. What version are you on?
    – Stijn
    Jan 12, 2018 at 11:35
  • Android Oreo 8.0 on OnePlus 5, so the option is visible? What phone are you using?
    – Matt07211
    Jan 12, 2018 at 11:36
  • 1
    I'm using a Nokia 8.
    – Stijn
    Jan 12, 2018 at 11:38
  • 1
    Hmm, Quick look around suggests the option will be available in 8.1 androidpolice.com/2017/10/26/… Also to note, all my other options are locked as well, so that sucks
    – Matt07211
    Jan 12, 2018 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .