I have a problem with my Motorola G1 smartphone. Recently, I did a factory reset and since then I have a problem with the language. My phone is set in English and I live in the Netherlands, but when I search something using the search bar in Chrome in a private window, Google is set to French. This is weird, since I do not have anything in French: not the language of my smartphone, nor the keyboard, nor my IP. And when I search, Google is set to google.nl, so the IP localization is right, but there is something wrong with the language, that is set to French. You can see this in the first picture.enter image description here

I noticed that I have the same problem when I have "integrated data" (I don't know if there is a better expression for this), for instance when a website reports an Instagram or Twitter post. An example is in the second picture. There you can see an Italian website, with my phone set in English and with a Dutch IP, however, you can see that the Instagram post reported in the website is in French.

enter image description here

I have really no idea how to fix this. I checked in Google settings, I changed the search language in Chrome to English, but every time I open a private window I see the results in French. Any clue on how to fix this?

  • Did you see your Google account settings?
    – user248200
    Jan 12, 2018 at 13:29
  • @Biswapriyo yes, and French does not appear anywhere
    – cholo14
    Jan 12, 2018 at 13:43

1 Answer 1


I actually solved my problem myself. On the Chrome app, I clicked on Settings-> Languages (in the Advanced category) and then I removed French from the language list, which apparently set to be my first language, I don't know for what reason. Now pages do not display anymore in French, so the problem is solved.

I would like to keep the answer on the website, it might be useful to someone, but admins can delete it if they think it is not useful.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .