1

aim: install LineageOS on the phone.

I tried to root the phone using the suggested sony method.

fast boot worked, the connection was given, the result was correct.

still, i had no root rights. so I couldn't go into recovery mode.

adb has the connection to the phone. I am able to reboot the phone with the command "adb reboot recovery" from my computer but doesn't go into recovery mode.

i tried to run "adb root" in the terminal on my ubuntu, didnt work either. so I tried the "adbd insure" app, didn't work because i had no root rights.

then again i tried the sony method of giving me root rights and the result said that it is unnecessary because it is already a rooted phone.

in the "phone info" on the g3311 the option "OEM-unlocking" is grey and unavailable to change.

afterwards i became desprite and switched to windows: tried towelroot, kingo root and oneclickroot. towelroot and oneclickroot said they arent currently supporting the version. kingo root just said that it failed.

How can i access root rights in order to install another operating system on the sony L1?

How can I access the Recovery Mode, other than with the ["press down volume" and boot] or [terminal-wise "adb reboot recovery"] methods?

OS on computer: Dual boot Windows 7 and Ubuntu 14

Brand: sony

Model: g3311

Android Version: 7.0 (43.0.a.6.49)

migrated from stackoverflow.com Jan 12 '18 at 15:31

This question came from our site for professional and enthusiast programmers.

  • Try this... – Selvin Jan 12 '18 at 10:44
  • alright will do. sony sent me here to ask this Q because they couldnt help me... – Hackybaby Jan 12 '18 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy