0

Recently, I purchased a 32Gb Kingston MicroSD card for my Alcatel Onetouch Pixi running Android 5.1 with all the latest available updates.

When I first inserted the card, everything worked as expected and the phone detected the card. The only odd thing was that, on starup, the phone would display "Optimizing apps" and spend a long time going through 100 or so apps, and this occured at every reboot. Nevertheless, I had access to the storage, so I tried moving a couple apps to the MicroSD. This seemed to work but I eventually got some errors while trying to move apps, even when trying to move them back to internal storage. I had to reinstall a couple of apps, but everything else seemed to work fine.

A bit later, I noticed that the "optimizing apps" screen didn't appear anymore, so I checked and the SD card was not detected anymore. There was no difference between having the SD card in the phone or not. However, my computer could detect the card just fine. Other android devices also detect it normally. I have tried another MicroSD card and got the same result.

I tried cleaning the card gently, reformating it, and resetting my phone, but nothing worked. The MicroSD card should be compatible with the phone according to the infos I found online, which would be logical since it worked at first.

Is it possible to make the card functional again?

1
  • When this happened to me, it was the card. It was an old card.
    – Max A.
    Jun 11 '19 at 17:13
0
  1. Is there an overheating issue in the phone/card combination, maybe? Some other compatibility issues (timings/delays) might play into here. (I had a similar issue with a 128 GB SD card on a Samsung s5mini, the card disengaged during use) My solution was to exchange the card for a different (well known) manufacturer/type. You could try doing this temporarily at first with a card from somebody you know.

  2. You could try testing your SD card for hardware errors on PC with H2testw (download source with high reputation) app, no formatting needed. Just reformatting the card doesn't force the storage controller to actually access higher sectors on the card, so this doesn't give information about the card being physically ok.

-1

I had an issue like this with the S4 (LTE), and in the end it was the actual tray.

But when it comes to external media in android there isn't much I can think of what could be a software issue.

Have you installed anything lately? - If so remove it

If you have updated, try resetting the phone (do not update it) and then try and put the card in, if you want a step-by-step guide of backing up apps (photos backup automatically if you attached your google account).

Sorry if I couldn't be of assistance!

Hope you resolve the issue and have a great day

3
  • While the first sentence sounds logical, I doubt anything else from your post applies. How should an user-installed app be responsible if the card isn't found even at boot? How should a reset cure that?
    – Izzy
    Jan 13 '18 at 21:12
  • He doesn't say anything about it not being detected at boot =P Jan 14 '18 at 9:36
  • Oh, he does – you just need to "read between the lines". Guess when that "optimizing apps" happens? So I'd interpret the 3rd paragraph the way that the card was no longer mounted at boot, and hence no "optimization" fired. To be 100% sure one needed to check the logs right after boot. That being said, an app could only come into play if it had the permission to MOUNT_UNMOUNT_FILESYSTEMS (or root powers at that). My bet would rather be "imperfect compatibilities": some devices have issues with some brands of cards. I'd simply check with a different brand of card before deleting stuff.
    – Izzy
    Jan 14 '18 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy