0

Every morning I turn off the alarm on my phone, look at it, see there aren't any updates and unplug it.

A few seconds later I'll start to receive several notifications about apps that need updates. These updates will not automatically download or install even though I've set that option in the Play Store; instead they sit waiting until I manually go to the Play Store and hit "Update All."

My phone spends all night plugged in and on Wi-Fi; why aren't they updating then?

For reference, I'm running an LG V20, with Android version 7.0. Play Store is version 8.5.39. If it matters, my alarm is set for 3:45 am. I didn't see any option in the store to change the update time.

  • 1
    @beeshyams even with that off, the apps should start auto-updating with the screen on if that setting were at fault. // Benjamin: Those apps might have been installed before you set to auto-update everything. Next time this happens, check the settings for one of those apps – auto-update is set per-app on install, with the setting you mentioned being the default. – Izzy Jan 17 '18 at 12:49
  • I checked the auto-update settings on one of the apps (Twitter) and it is enabled on that app. – Benjamin Chambers Jan 17 '18 at 13:27
  • "Keep Wi-Fi on when screen is off" says "Yes" – Benjamin Chambers Jan 17 '18 at 13:29
  • OK, that's weird now.Do PlayStore and Play Services auto-update themselves, or are they also part of that "pending list"? IOW: Is anything at all auto-updating, or does it affect all apps? Not that I see a pattern, but it might provide a clue to someone else. – Izzy Jan 17 '18 at 15:15
  • You can try signing out of your account and setting it up again – beeshyams Jan 18 '18 at 6:34
0

Guys this is an easy fix and the reason is pretty easy to determine. The reason is because of Androids "Optimize battery Usage" feature it puts the google play store to sleep or google play services and restricts background activity. This means that when your phone screen turns off the app is put to sleep so it does not consume battery or if the phone is charging it doesn't have any background activity access. to fix this you need to go to settings, apps, and scroll until you find Google Play Services and Google Play Store. Check Google Play store first click it and then click battery if you see that it says optimized click the Optimize Battery Usage button and it will take you to a list at the top change it from Apps not optimized to All. Scroll down the list until you find Google Play Store and turn the toggle switch to off repeat this process for Google Play Services (most likely this will not be optimized but just in case check). Now that you have done this your phone will update because the app will no longer be put to sleep and it will be allowed to work in the background while your phone is charging or on Wi-Fi and it will update your apps. I have fixed this issue on a few phones and if this does not work for you there is something else wrong with your device or android.

New contributor
aaron johnson is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.