0

I want to flash the new Update for the OnePlus 5T but TWRP is not asking for a decryption password as usual and hence cannot mount the data partition.

It's possible that this is not working since the last update (OnePlus 5T OxygenOS 4.7.6).

Is there a way to force the decryption, for instance by some command in the TWRP terminal? Or is there a way to reset this?

In the Android settings, the Encryption Option is not changeable, it just says "Encrypted".

UPDATE: Obviously OTA Updates are possible now, I don't know how. Till now, with custom recovery and/or root this was an issue and not possible so you had to download the Update manually and install it through TWRP or other recovery.

During OTA Update, the recovery was overwritten with the original from Oneplus.

The option for Smartphone encryption in the settings remains unchangeable, so I believe I could not change the code if I wanted to.

4

From the TWRP terminal enter the command twrp decrypt <your password>

Source

  • I tried this before I updated through OTA and it wouldn't take my password. Atm, I don't know how to flash TWRP now, I tried in fastboot but after rebooting to recovery, the Onplus Recovery came up again. For a fully working system (unfortunately, I don't know what's the matter here with my phone), I think this would be the answer to my original question nevertheless, so I will mark it as the answer. Thank you! – Martin Jan 18 '18 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.