0

Unable to tap on the INSTALL button for an app (that I created). Cancel button works fine.

I have looked into other answers and they all seem to be talking about screen dimming / blue light filter apps - I am not using any screen dimming or blue-light filter app/tool, or have any such settings on (that I am aware of).

My phone is an Honor 6X. Its a phonegap/ cordova app that I created for my personal use. Have been using it for months, and have installed updated versions many times with no issue. Few days ago, while using the app - it got stuck (it was writing a lot of data into an SQL database) when it sorta hung up for a long time. So I closed the app - and after that it stopped working. It just won't start again. (I guess the SQL file got corrupted because I forcefully closed it when it was still writing data)..

I uninstalled it, and when I tried to reinstall again - the INSTALL button won't work - seems to be inactive.

I then changed the app ID (reverse domain id), app versions etc - and tried to install it as a new app - but that didn't work either.

Finally, I downloaded another third party app - (which I had successfully installed on my phone before) - and same issue - unable to tap the install button. So it looks like I am unable to install any kind of third-party app, not just that app. Can somebody help?

  • Are you able to give runtime permissions to app? – global_warming Jan 20 '18 at 20:31
  • Try installing with ADB Shell. If the problem persits, you might need to perform a factory reset that may solve it. – esQmo_ Jan 20 '18 at 22:28
  • Do you have any type of screen filter app switched on? In such cases, these problems do occur, like in my case. – Wrichik Basu Jan 21 '18 at 7:50
  • Well, this might sound stupid but when you are on the install screen lock your phone and then unlock it(by pressing the power button) and then see if it works. It worked on my Amazon Kindle fire. – AnuthaDev Jan 21 '18 at 12:26
  • 1
    No, the problem doesn't lies with your app "MBMT". Package Manager is used to install apps means you won't be able to install any app. I would suggest you to revoke 'draw over other apps' from all apps that are allowed (have draw over other apps ON) and then try installing. – global_warming Jan 22 '18 at 17:13
0

Anurag's suggestion worked for me. From the install screen lock your phone with your power button then unlocked and voila there's the install button

-1

Same problem as I had.. My trick is to DL the app then open download folder tap the app, scroll down to the no install.. Hit back then tap on the install screen u see.. Voila it now allows Install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.