I have just found an app in my apps menu (pictured below), but it doesn't have a name or proper icon.

I have looked in the app info menu in settings, but I can't see anything.

My phone is a Sony Xperia XZ. It's running android 8.0.0

Does anyone know how to get rid of this?

screen cap of my apps menu

  • Can you find it in application list in settings? Can you frag and uninstall it? What does it do when you click on it? Jan 21, 2018 at 18:18
  • As I said, it's not in settings. When I tap on it in that menu nothing happens. If I long tap then I can move it to home, but nothing else.
    – Matt Ellen
    Jan 21, 2018 at 18:25
  • Try using Malwarebytes Antimalware. Jan 21, 2018 at 18:33
  • Did you try restarting your phone?
    – aBochur
    Jan 22, 2018 at 0:08
  • This may help
    – beeshyams
    Jan 22, 2018 at 2:08

3 Answers 3


Usually that is a virus app(no name and no icon and can"t uninstall) and you can uninstall it by using malware cleaner apps

  • Android doesn't have viruses. Maybe a malware. Jan 21, 2018 at 18:17
  • I tried AVG, but it hasn't found anything
    – Matt Ellen
    Jan 22, 2018 at 8:29
  • Try to use Kaspersky mobile if it don't work that mean your malware is very bad
    – AlphaBetA
    Jan 23, 2018 at 0:07

Go to app store and see if there is an app which is on hold and has not been downloaded yet. It might have some error and so is stuck. Else scan your phone once. It can be a malware.


I don't know why this fixed it, but A bochur's suggestion to restart my phone has removed the app from the app menu.

If someone know what caused this behaviour I'd be grateful to know, otherwise: case closed.

  • One possible reason is aborted download - I linked one such case in the comment beneath the question
    – beeshyams
    Jan 22, 2018 at 13:17
  • Oh! Thanks. I don't remember doing that, but it's possible.
    – Matt Ellen
    Jan 22, 2018 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .