I have an Alcatel One Touch Idol 3 model 60451 running Android 6.0.1 and it updated a few days ago turning File Manager into adware that would reinstall itself no matter what I did. I tried everything I could find on the internet, including from Is this "Boost" / File Manager app a true system app or malware?.

I did as suggested and stopped auto-updates in Google Play. The only difference was that Google Play wasn't showing any apps when I clicked there. But I still was able to select no auto-updates in settings in Google Play. It hasn't reinstalled again for a while, but it's back. It's beginning to look like a factory reset is in order and then doesn't allow any more updates.

Finally, I did a full factory reset after stopping all updates on Google Play and the automatic restore on the phone and it not only appears again, it has another toolbar with it. Actually I did this 4 different times, all the while stopping everything that could be stopped. Finally, I closed down my Google account entirely and then did a factory reset. The result, it's back. File Manager comes with the phone but until an update last week it was unobtrusive.

I have never downloaded it deliberately or rooted my phone or downloaded an APK file or anything other than Google Play apps. I have been working on this for the past several days (obsession) and don't find any way to get rid of this.

Is it possible to delete Alcatel File Manager completely?


In Settings - Apps - File Manager delete the updates of this app. This will revert the app to the initial version.

If you don't want to use the app anymore (which would be my advise since Alcatel File Manager is not so great), disable it completely.

  • Thanks but I have done that at least 50 times (yes I am obsessive) It just comes back in less than a minute and that is after Disable and Force Stop and Clear Data. Oddly enough after searching the internet for days, as soon as I asked here for help I found an answer at least so far and I will put it in Answer Your Question.
    – Rev. Jack
    Jan 23 '18 at 8:12
  • It's strange. I disabled the app and it doesn't bother me any more. Jan 23 '18 at 8:15
  • I think this may have something to do with Alcatel phones in particular. At least that is what others have said who have the same problem.
    – Rev. Jack
    Jan 23 '18 at 8:26
  • I've got One Touch Idol 3 too, but 6039K, not 60451. No problems with it. Jan 23 '18 at 8:29
  • I am glad you are free of this problem. I have actually enjoyed my phone up until now and really haven't had many problems with it. That is until the last update.
    – Rev. Jack
    Jan 23 '18 at 8:35

I had the same problem with file manager as well as joy launcher. I read something that worked for me. Turn off your Wi-Fi and your mobile data. Then Settings > apps > file manager > click on the three dots at upper right > Uninstall updates. This finally worked for me. I chose Google Now Launcher as my replacement launcher which I installed from Google Play Store before beginning this process.


I just found a post that said, "This issue is there in most of the cheap Chinese phones and tablets. These phones have a pre-installed trojan program which cannot be removed from the phone."

They suggested NoRoot Firewall (available at Google Play) and it really stops programs from using the internet without your permission. It stopped File Manager as well as OfficeSuite (which I had previously uninstalled) from internet access. Now File Manager cannot reinstall itself. Now I am just keeping my fingers crossed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.