1

I recently changed out several android TV PCs to TX92 hardware with android 7.1.2. I use them to remote into Windows as a thin client among other things. The last nuisance remaining is the home key. If using Windows and I press the home key on the keyboard, android goes back to the launcher screen. How can I disable this? The units are rooted.

3

I doubt this is possible.

From Android Developer Center (Google's official site):

Key code constant: Home key.

This key is handled by the framework and is never delivered to applications.

And the Home key on a generic QWERTY keyboard is mapped to the Android "home" button, so it's treated the same as the real home button.

You can try modifying /system/usr/keylayout/qwerty.kl but as per my attempts, it doesn't work. Just in case it would work for you, for what it's worth, I changed

key 102   HOME

to

key 172   HOME
  • The boxes I replaced had android 4.4.2, I think it was, and there was an option in settings whether the OS should recognize keyboard hotkeys. In many ways they worked better than what I have now with 7.1.2. The processor was just too slow. I waited a long time to swap out. – subjectivist Jan 25 '18 at 23:51
  • This worked! There was a note inside qwerty.kl saying it isn't the default for android any longer, but Generic.kl. I commented out anything saying home, which did not work, but did the same for all files in the folder. Some had a home assignment, some did not. Probably a vendor specific file is being used. For people reading, you must reboot after changing keyboard files for change to take effect. – subjectivist Jan 26 '18 at 0:58

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.