0

I have a Nexus 5X, which I've had for 2 years and used without any serious problems until today. It is now running Android 8.1. I have Ting as my carrier.

I'm having a strange issue. Most of the time, I see an X over the signal strength indicator, and if I try to connect to the internet, it takes a long time and then tell me the site can't be reached (see the first screenshot).

Here is the strange part: if I connect to a WiFi connection, everything works fine and the X goes away (see the second screenshot). If I disable WiFi, the X comes back and I can't connect. I can't stay connected to WiFi everywhere I go all the time, so I'd like to fix this problem.

I tried googling for problems like this and tried everything that was suggested: I restarted my phone multiple times, I removed and reinserted my SIM card, and yes I'm sure I have mobile data enabled.

Does anyone know why this is happening or how to get my internet connection working like before?

Google with WiFi disabled Google with WiFi enabled

1
  • 1
    Does calling with fine? Also, did you have a look at your apn settings?
    – aBochur
    Jan 25, 2018 at 3:21

1 Answer 1

0

I figured out what was causing the problem. I had been using my phone as a hotspot, and it used an unusual amount of data, causing Ting to cut off my connection. I called their support number (1-855-846-4389) and talked to someone, and they re-enabled it.

2
  • There may be two possiblities, 1. With APN settings. 2. As you said that, you're using your phone as hotspot, may be your device's data limit(mobile data, not wifi) had been reached, and device may have stopped it.
    – Rahul Gopi
    Jan 25, 2018 at 5:37
  • I don't think my device stopped it. According to the support person I talked to, Ting automatically turned off my connection to prevent my bill from becoming too big. Jan 25, 2018 at 6:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .