1

When i connect my android 5.1 phone to pc as mtp device to send and receive files it shows unrecognised device in Windows (tried in win 7and 10) and can not open mtp device on linux (tried in ubuntu 16.04). I also tried to update mtp drivers on Windows but still it doesn't work.

0

I have ever had experience the same problem as yours. Mine problem is the cheap USB cable which I use to connect my android phone to pc. Once I replace it with a higher quality USB cable this problem was solved.

0

I've had this problem with a lot of devices especially after lollipop. But you can definitely try this. Get a file share app like shareit or Xender and connect it to your computer via WiFi or hotspot. It's wireless, free, fast but not as fast as through cable and it works very well. Hope this helps.

  • Wireless file transfer is good. I used adb pull to copy files it is working but the problem is with mtp device, no drive is visible in file explorer when the device is connected – ashu Jan 26 '18 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.