1

I have a new Moto E4 running Android 7.1.1. The system and all applications are up to date, as of today. However, when I try to open certain applications (Mendeley, Fitbit, and MyTracks, to name a few) the apps just show a blank white screen. They don't load.

My phone is not rooted and is using the default Android 7.1.1 that came with it. I found some discussions online that said I need to enable Android System Webview, but when I find this app in the Play Store and click Enable, nothing happens (and the button still says "Enable").

Since this happens across numerous apps, it seems like this is a system wide problem. What am I doing wrong?

  • @beeshyams It sounds like I need root if I want to view log files, which is unfortunate. If an app can only view its own log files, and the apps themselves don't open, that puts me in a pinch. – Michael A Jan 30 '18 at 21:54
  • 1
    There are different ways of accessing the logs, not all of them requiring root. Think e.g. of the adb logcat command ;) – Izzy Feb 1 '18 at 7:01
0

The problem stemmed from where these apps were installed. By default, my phone was installing apps to the external storage (which was formatted as part of the file system). While this worked fine for most apps, it caused these apps to crash. Once I went into Settings and moved these apps to internal storage, they worked as intended.

0

If the problem persists try running the command "ActivityManager" via ADB. It might be the start-up time for the app itself try running this command :

tns create app1
cd app1
tns platform add android
tns run android --justlaunch

Or this command to troubleshoot...

I/ActivityManager(XXX): Displayed org.nativescript.app1/com.tns.NativeScriptActivity: +XsXXXms

Also, Just a stab in the dark, but if it's the problem I think your having, try running this command to help:

exports.navigatingto = function() {
    setTimeout(processingFunction, 0);
};

With any luck that command might reset everything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.