2

I want to root my phone, but first I was trying to install TWRP. The phone is Galaxy A3 SM-A320FL (2017). (Edit: System is Android 7.0)

What I did:

  • Turned on OEM-unlock and USB-debugging on the phone
  • Installed the Samsung USB drivers on my laptop
  • Turned off phone, went into "Download Mode" by pressing Volume down - Home - Power
  • Started Odin. Connected the phone. In Options I ticked only "Auto Reboot" and "F Reset Time"
  • Clicked on AP and selected the TWRP file and hit Start
  • Then PASS was flashing in Odin and the phone rebooted immediately.
  • Turned it off and tried to enter recovery mode. (I think I did it with Volume Up - Home - Power)

...and then a blue screen came and said "Installing system update". After a while it changed to a blue screen that said "No command". Then after a while it changed to a screen that I think is the standard recovery tool. So no TWRP. I hit Reboot and the phone rebooted normally.

Then tried to do the whole thing again with a different TWRP file but it went exactly the same. I'm newbie with all this so I might be using a wrong TWRP file or something, I also seen tutorials where it says dont thick Auto-Reboot and they press all sorts of button combinations. I don't want to brick this phone so I wanted to ask how to do this right before I try it again. Thanks for help!

1

For those that came here, the problem is that when booting, twrp is erased by stock recovery. The goal is to avoid the normal boot. Firstly, uncheck "Auto Reboot" in Odin. Then finish others Odin steps, and when you see PASS here we go:

  1. Volume down+Home+Power to exit installation/start reboot process.
  2. Instantly when something change (screen should turn black) switch to Volume UP+Home+Power (combinason to enter recovery mode), and there it should be okay. (if you are too slow it will again boot normaly and twrp will be gone again).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.