0

I am using a device running on AOSP 8.1

Recently I wanted to automatically turn hotspot on when device boots but Macrodroid is unable to do so

Help required!

  • 1
    Please mention what you did in your macro- that would make it a better question – beeshyams Jan 31 '18 at 16:07
  • I though you'd figured out as you mentioned in your previous post anyway you can still try the tasker method if need be :) – xavier_fakerat Jan 31 '18 at 16:27
  • Actually after answering that question I wanted to do same on Oreo but as google has changed Tethering API methods none of the apps whether be Tasker or Macrodroid are unable to do so. – Pranjal Feb 1 '18 at 10:24
0

A rooted device has likely been required since Android 7, where it begun to cause DHCP issues otherwise, since Android 8.1 certainly. Earlier it depended on the device manufacturer or carrier. Automate has a Wi-Fi hotspot set state which should work in any case.

0

Here is how to start your hotspot after booting/rebooting using Macrodroid:

  1. Select Device Boot in the Triggers section.
  2. In the Actions section. select Hotspot On/Off. A message/notification will appear, press OK, select Enable Hotspot.
  3. Give the macro a name, then save it.

Note: I found that it's better to test the macro before rebooting for it to work as intended; not testing did not start the hotspot after rebooting the phone. The macro has been tested on a rooted Lineage 14.1 and non-rooted Android 8.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.