4

I have several WiFi APs for different purposes. One is for printing, one is for smart devices with access to the internet, another for devices with no access to the internet for security concerns, and some others like repeaters, guest APs or streaming devices. Android 7 always switches between these APs without asking for permission. The only time it asks for confirmation is when switching from WiFi to mobile data. Using the wrong AP, is not only annoying but has unwanted consequences. Any idea how to stop Android from such nonsense move?

Ps: there is no smart wifi option but wifi plus which is off. Ps2: Imagine an app does not have access to the AP or internet it needs or when setting up a device and the WiFi is switched to another AP or connecting to a server with the wrong IP, just because Android decides it wants to use a different WiFi AP.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • is there any chance you have set Keep Wi-Fi on during sleep to Never (Wi-Fi->Configure Wi-Fi(Settings icon)->Keep Wi-Fi on during sleep)? This will turn Wi-Fi off when phone goes to sleep and when it wakes up, it will get connected to any of your available APs at that time based on signal strength. – global_warming Feb 5 '18 at 7:53
0

I had that issue. I have 2 APs and my phone keeps switching between the 2. What I did was made the phone "forget" the APs I DON'T usually use the phone with. Can't connect to an AP you don't have a password for, right? Works like a charm.

  • Thanks a lot for your input, at least I see other people have the same issue. It might benefit some. I do this sometimes but there is no prefered AP and I need to constantly use these APs, and re-establishing the connection with long passwords each time would not be very user-friendly. I'd rather see android sticks to the WiFi AP that it was assigned to. – pal Feb 5 '18 at 4:39
  • My same solution, answerer. A shame there isn't a more user-friendly way. – Death Mask Salesman Feb 9 '18 at 13:14
0

In Android 7.0, you can actually disable wifi auto-reconnect. Go to Wifi Settings, then tap on one of the AP. Uncheck the Auto-reconnect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.