My new wired earphones have a one-button in line remote. Two common uses of pressing this button include:

Option1. Pausing and resuming music playback;

Option2. Opening and dismissing an audio Google search.

But, I am only interested in Option1. At first I found all I could make the button do was Option2; even after I disabled Google's microphone access, Option2 still happened instead of Option1 (but of course Google couldn't hear anything, so although the search app opened it didn't attempt to discern a search string.) After I restarted my phone, pressing the button does Option1 and Option2 simultaneously. In particular, the Google app is brought to the front (whether it's currently open or closed), and stays in the front even when a second dismissal button press occurs.

My question, therefore, is how to stop this app coming to the front. I wouldn't mind it opening so much if the app I want to use stayed at the front. In theory the solution is to change the headset settings so the button doesn't have a search effect. However, I haven't managed to do this because:

  • When I search settings changes that should do it, the menu options they list are unavailable, possibly due to the instructions being out of date or my phone being unusual;
  • I have also tried several headset-controlling apps, but none worked (some didn't even seem to have a relevant setting).

Thus my question concerns how to prevent an uninteresting app from focusing.

1 Answer 1


In case anyone has this problem in the future, I fixed it by force-stopping the undesired app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .