1

background:

  • I have a new phone, Google Pixel 2, that does not have a 3.5 mm headphone jack
  • about 4 times out of 5 times when I try to use wired headphones --> the sound does not come out of the headphones but instead is emitted from the phone's speakers

things i've tried:

  • I have tried unplugging and plugging in the "USB-C to 3.5 mm headphone adapter" (or just "USB to headphone adapter" for short) and sometimes this gets the audio to come out of the headphones.
  • But many times no matter how many times (10+ times) I try unplugging/plugging the "USB to headphone adapter" into the phone... the audio does not come out of the headphones.

When no sound comes out of wired headphones connected to "USB to headphone adapter", how do you get the sound to work?

1

The only workaround I have found to work reliably is:

  • restart the phone right before you need to use the wired headphones with the "USB to headphone adapter"
  • after the restart, the sound always works on my wired headphones connected to the "USB to headphone adapter"

(

Side note:

  • The fact that I have to restart the phone and this causes the sound to always work... IMO indicates a software issue.
  • Some sort of Android service that detects the adapter being plugged in is not working properly and the restart ensures that the service is working properly.
  • Most likely if someone with better expert knowledge knew exactly what service needed to be restarted... restarting that service would be a better solution (probably faster to restart one service instead of the whole phone... and doesn't interrupt what you are doing on the phone like a restart).

)

| improve this answer | |
1

I have an HTC U11. My headphones quite mysteriously stopped working. None of the tips online (audio output apps, restart, etc) helped. I finally chanced across the culprit: power-saving mode. The audio jack adapter toolkit needs background data access. Power saving mode restricts background data access. My solution: Go into settings, apps, select show system apps from menu, find the audio jack adapter toolkit, open data usage, and give the app unrestricted data access. Voila, sound over my headphones. Hope it works for others out there too.

| improve this answer | |
0

FIXED!!! I found the fix for this issue (atleast fixed it for my pixel 2 xl)

Goto Settings -> developer options -> Disable automatic routing to USB audio peripherals , and disable this option if it's enabled.

Try it out and let me know how it goes 😊.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.