3

I gave admin rights to two apps I have on my Motorola Moto G5 Plus (Android 7.0): Find My Device; Greenify Automator. The first one I mean to keep it as admin, but I would like to remove Greenify. When I try to do so, it simply won't let me. I try selecting "Deactivate this device administrator" but nothing happens. And nothing happens either if I try selecting "Cancel". It seems like these two buttons are just deactivated. I then also tried doing the same for Find My Device, and it also doesn't work. So I guess it's some kind of bug when removing Device administrators.

Someone know how to solve this?

[

3

It was blue light screen filter that was causing the problem and deactivating that fixed the problem as confirmed by OP .Tinted screenshot lead me to suspect this :-)

For additional details on what such apps do see What does "Drawing over other apps" mean?

2

It's very possible that a third party app, is in your way. Therefore, you should try removing administrator rights, while in safe mode. Because while is safe mode, all third party apps are disabled.

To go into safe mode, turn your phone off, and when turning it on, press and hold the volume down button. When it's fully powered on, it'll say safe mode on the bottom left of the screen.

Now try removing administrator rights while in safe mode.

  • You can also hold down restart in the power options. I think a device without the restart button binds it to holding shutdown instead, but that may need checking – Dan Brown Feb 13 '18 at 7:39
  • @DanBrown holding down on the word restart, did nothing. Do you mean that after pressing restart I can hold down on the volume down button till safe mode? I know that but didn't want to make the answer more complicated with too many options – aBochur Feb 13 '18 at 16:31
  • Hmm, try holding power off instead. I can verify that works, at least (just tried it) – Dan Brown Feb 13 '18 at 21:16
  • @DanBrown just tried in a Galaxy s5, doesn't work. Probably a feature added by your phone manufacturer or removed by Samsung – aBochur Feb 13 '18 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.