I have a Google Pixel 2 and I would like to add an external calendar to my Google Calendar.

If I use my computer, I can login into my Google account (the same account I'm logged in with my phone), go to the apps and open the Google Calendar. Once there, I can add a new calendar by providing a URL, and automatically the new events of that calendar are added to Google Calendar.

I was expecting to see those events in the Google Calendar of my Pixel 2, but they don't appear. What am I doing wrong?

  • Have you tried the obvious, like selecting the calendar in the menu on the left, while in the calendar app?
    – aBochur
    Feb 13, 2018 at 16:48
  • That's the thing, in the website I can see the new added calendar on the left, under the "Other calendars" section. But in the mobile app that calendar doesn't appear. I only have two options, "Birthdays" and "Holidays", which seems to be two predefined calendars on the mobile app. Feb 13, 2018 at 16:58

3 Answers 3


I think the Google Calendar app for Android doesn't support that functionality.

From a computer:

  1. I open a Google Calendar, for instance this one
  2. I click on the add to Google Calendar button.
  3. That calendar gets added to my Google Calendar.

From an Android phone:

  1. I open a Google Calendar, for instance this one
  2. I click on the add to Google Calendar button.
  3. The Google Calendar app opens and displays the message "Calendar couldn't be added".

According to the response from a Google representative, "there isn't an option to add external calendars to the Google Calendar app".

  • This answer is partially incorrect. While it appears that you cannot add a calendar from a url using the app, you can view a calendar that you have added via the desktop calendar, using the app. See Susan's answer for details. android.stackexchange.com/a/216608/300843
    – Jacob
    Aug 12, 2020 at 3:52

From Official Google Support - Calendar Help - Fix sync problems with the Google Calendar app,

Check that Calendar is synced

  1. Open the Google Calendar app Calendar.
  2. In the top left, tap Menu Menu.
  3. Tap Settings Settings.
  4. Tap the name of the calendar that isn't showing up. If you don't see the calendar listed, tap Show more.
  5. At the top of the page, make sure Sync is on (blue). You'll only see the Sync setting for calendars you've created, but not your primary calendar (this is usually called "Events" unless you've changed its name).

Note: It might take some time for your events to show up after you turn on sync.


I found a useful Youtube video helping me with what I assume is the same problem.

What is explained in the video is that in the Google Calendar app, if the calendar doesn't show in the list of calendars, try to open settings and scroll down and find the link "show more", where you should be able to find the calendar you are looking for. Simply click on it and turn on sync.

It worked for me with a calendar I had added via URL to my Google account on desktop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .